error message on trying to update asciidoctor-pdf

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

error message on trying to update asciidoctor-pdf

Elisa
I am copying information into a new post so that it's clear what problem I'm not trying to solve. Please both pardon me and correct me if this is not how I should be handling this. :-)

I am running RVM and got into some snarly issues with attempting to update to latest versions of Ruby, asciidoctor, and asciidoctor-pdf. Right now I have RVM set to run 3.0.0.

As a tech writer I have found having RVM useful but am a rather naive user. I might have inadvertently created some sort of conflict in trying to update RVM, Ruby, and gems that are needed to run asciidoctor. This recently became a time sink for me.

As indicated in my prior post, I need to be able to have footnotes in my pdfs.

Here is the error that I get when trying to update to the latest asciidoctor-pdf:

$ gem update asciidoctor-pdf
Updating installed gems
Updating asciidoctor-pdf
ERROR:  While executing gem ... (NoMethodError)
    undefined method `request' for nil:NilClass

Any ideas?
Reply | Threaded
Open this post in threaded view
|

Re: error message on trying to update asciidoctor-pdf

abelsromero
Simple option, use Ruby 2.7.x for now. asciidoctor-pdf has some issues with 3.x, seems similar to this one https://discuss.asciidoctor.org/Unable-to-install-asciidoctor-pdf-td8487.html#a8492.

In short:
$ rvm install ruby-2.7
$ rvm remove ruby-3.0.0
$ gem install asciidoctor-pdf

Check you only have one version of asciidoctor and asciidoctor-pdf with "gem list | grep asciidoctor". If you have more than one, "gem  uninstall GEM_NAME GEM_VERSION" to remove the ones causing troubles.
Reply | Threaded
Open this post in threaded view
|

Re: error message on trying to update asciidoctor-pdf

abelsromero
In reply to this post by Elisa
About the footnotes, I could generate a PDF successfully with this versions (below) and command "asciidoctor-pdf -d book demo.adoc".

 >>> ruby -v
ruby 2.7.0p0 (2019-12-25 revision 647ee6f091) [x86_64-linux]

~ >>> gem list | grep asciidoctor
asciidoctor (2.0.10)
asciidoctor-pdf (1.5.4)

I created a document with a 2 pages section, added couple of footnotes in the text, and they are linked, numberd and appear at the end of the section (not the document). I hope this bring some peace of mind :)


Reply | Threaded
Open this post in threaded view
|

Re: error message on trying to update asciidoctor-pdf

Elisa
In reply to this post by abelsromero
I am getting an error when I try to remove Ruby 3.0.0:

$ rvm use 2.7.2
Using /Users/storycraft/.rvm/gems/ruby-2.7.2
$ rvm remove ruby-3.0.0
ruby-3.0.0 - #removing rubies/ruby-3.0.0...................................................................|
Error running '__rvm_rm_rf /Users/storycraft/.rvm/rubies/ruby-3.0.0',
please read /Users/storycraft/.rvm/log/1613673232_ruby-3.0.0/remove.rubies.log
Using /Users/storycraft/.rvm/gems/ruby-3.0.0

Reply | Threaded
Open this post in threaded view
|

Re: error message on trying to update asciidoctor-pdf

Elisa
Here's an update, although I could not uninstall Ruby 3.0.0, I can get the footnotes working by specifying the use of 2.7.2--just had to install some gems after specifying 2.7.2 to get it working. So I'm good for now.

I might end up with some questions about using latexmath. :-)

Thanks for the help.
Reply | Threaded
Open this post in threaded view
|

Re: error message on trying to update asciidoctor-pdf

mojavelinux
Administrator
I'm glad to hear you got it working!

When using RVM, you don't need to uninstall a Ruby version (unless you really want to). You install the version you want, then switch to it.

I know the conflict between Asciidoctor PDF 1.5.x and Ruby 3 is a real pain. It hit at a really inconvenient time for me. But I'm working on getting Asciidoctor PDF 2 released, which will solve it.

I have heard that the following works to get Asciidoctor PDF 1.5.x installed on Ruby 3, but it's not the official solution:

 gem install --pre asciidoctor-pdf

Best Regards,

-Dan

On Thu, Feb 18, 2021, 11:48 Elisa [via Asciidoctor :: Discussion] <[hidden email]> wrote:
Here's an update, although I could not uninstall Ruby 3.0.0, I can get the footnotes working by specifying the use of 2.7.2--just had to install some gems after specifying 2.7.2 to get it working. So I'm good for now.

I might end up with some questions about using latexmath. :-)

Thanks for the help.


If you reply to this email, your message will be added to the discussion below:
https://discuss.asciidoctor.org/error-message-on-trying-to-update-asciidoctor-pdf-tp8512p8516.html
To start a new topic under Asciidoctor :: Discussion, email [hidden email]
To unsubscribe from Asciidoctor :: Discussion, click here.
NAML