Grégoire,
To make it more readable, you can consider doing something like this:
ifdef::myAtt[Test new function]
ifndef::myAtt[Test]
Or even add some comments to make it clearer:
// myAtt is defined
ifdef::myAtt[Test new function]
// myAtt is not defined
ifndef::myAtt[Test]
Marc.