asciidoctor.js installation fail

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

asciidoctor.js installation fail

viridis
Sorry if this is a noob question, but I am not able to install asciidoctor.js in my linux machine. Following the instructions: http://asciidoctor.org/docs/install-and-use-asciidoctorjs/#setup
  $ cd asciidoctor.js
  $ bundle
  Could not locate Gemfile


What I am missing? The git clone appears to be ok, got ruby and such stuff, but have no clues on the docs.

Help!?
Thanks!

Reply | Threaded
Open this post in threaded view
|

Re: asciidoctor.js installation fail

mojavelinux
Administrator
That document is out of date (thanks for the heads up). Here's the one you need to follow to build the project.


But if all you want to do is use the software, you can just install it from npm:

 $ npm install asciidoctor.js

You can find more details in the project README:


Cheers,

-Dan

On Wed, Oct 4, 2017 at 4:40 PM, viridis [via Asciidoctor :: Discussion] <[hidden email]> wrote:
Sorry if this is a noob question, but I am not able to install asciidoctor.js in my linux machine. Following the instructions: http://asciidoctor.org/docs/install-and-use-asciidoctorjs/#setup
  $ cd asciidoctor.js
  $ bundle
  Could not locate Gemfile


What I am missing? The git clone appears to be ok, got ruby and such stuff, but have no clues on the docs.

Help!?
Thanks!




If you reply to this email, your message will be added to the discussion below:
http://discuss.asciidoctor.org/asciidoctor-js-installation-fail-tp5958.html
To start a new topic under Asciidoctor :: Discussion, email [hidden email]
To unsubscribe from Asciidoctor :: Discussion, click here.
NAML



--
Dan Allen | @mojavelinux | https://twitter.com/mojavelinux