Quantcast

asciidoctor-diagram: wrong image format for graphviz

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

asciidoctor-diagram: wrong image format for graphviz

wimalopaan
Recently the behaviour of graphviz generated images changed. Since recently the generated images were in vg format. Now I have to specify the format explicitly (see example: first block).

If I omit the format specifier, I get an pdf image, but that cannot be included into the html !?

[graphviz, format="svg"]
----
digraph G { 
  V [shape=record; label="<l> a | b | ... | z | '\\0' ";]; 
  Zeiger_1 -> V:l; 
}
----

[graphviz]
----
digraph G { 
  V [shape=record; label="<l> a | b | ... | z | '\\0' ";]; 
  Zeiger_2 -> V:l; 
}
----

There must be an change in asciidoctor-diagram, but I can't say excactly when this happened.
Is this a know bug?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: asciidoctor-diagram: wrong image format for graphviz

abelsromero
The change was introduced in the last version (1.5.3) but I don't see any suspicious commit. 1.5.3 mainly adds support for Umlet.
Also, seeing the tests (with my limited Ruby experience) it seems that there's no test that checks the default format.

So, I'd say it's a issue, some likely side effect. If you can, just file an issue in the GitHub repo (https://github.com/asciidoctor/asciidoctor-diagram). I am sure Pepijn will take care of it, great guy.
Loading...