asciidoctor-ant: why no directories starting with '_' in the entire absolute path?

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

asciidoctor-ant: why no directories starting with '_' in the entire absolute path?

Julie
Hi,

I'm trying to use the asciidoctor-ant task through cygwin, and bumped into a problem with the task ignoring all my files because my files live in a subdirectory of my loadbuild output directory, which happens to start with a '_'.

Example:

/project - contains build.xml
/project/_loadbuild - target for all loadbuild activities
/project/_loadbuild/docs
/project/_loadbuild/docs/adoc - home of some (generated) .adoc files
/project/_loadbuild/docs/output - target directory for html files

My ant task parameters specify "sourceDirectory=docs/adoc" and "outputDirectory=docs/html".  

I added debugging statements to AsciidoctorAntTask, and I can see that directoryWalker.scan() is returning a list of ~50 files (correct), but then they're all getting removed by secondary looping that's happening in scanSourceFiles(), where the parent directory of each file is checked to see if it starts with an '_'.

I can also see that the getAbsolutePath() result of everyone of those files starts with c:\...  I'm speculating that this means that the directory matching loop stop on line 279 won't work against a relative path as the sourceDirectory.

Is this deliberate behaviour?  If so, can anyone think of a workaround?  Specifying absolute windows paths to ant in cygwin seems fraught with peril.  So does changing the name of the _loadbuild directory, which could affect a lot of downstream tooling.

Thanks,
Julie
Loading...