Unable to get asciidoctor-diagram working

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Unable to get asciidoctor-diagram working

wimdeblauwe
Hi,

I am trying to get asciidoctor-diagram working for the first time. I am using asciidctor 1.5.6.1:

Wims-MacBook-Pro:docs wdb$ asciidoctor -v
Asciidoctor 1.5.6.1 [http://asciidoctor.org]
Runtime Environment (ruby 2.4.2p198 (2017-09-14 revision 59899) [x86_64-darwin16]) (lc:US-ASCII fs:US-ASCII in:- ex:US-ASCII)

When I run "asciidoctor -r asciidoctor-diagram", I get:

asciidoctor: FAILED: 'asciidoctor-diagram' could not be loaded
  Use --trace for backtrace

Also with asciidoctor-pdf, I get the same error. Version:

Wims-MacBook-Pro:docs wdb$ asciidoctor-pdf -v
Asciidoctor PDF 1.5.0.alpha.16 using Asciidoctor 1.5.6.1 [http://asciidoctor.org]
Runtime Environment (ruby 2.4.2p198 (2017-09-14 revision 59899) [x86_64-darwin16]) (lc:US-ASCII fs:US-ASCII in:- ex:US-ASCII)

I installed asciidoctor-diagram through `gem`:

Wims-MacBook-Pro:docs wdb$ gem which asciidoctor-diagram
/Library/Ruby/Gems/2.0.0/gems/asciidoctor-diagram-1.5.5/lib/asciidoctor-diagram.rb

Any idea what else I can try?
Reply | Threaded
Open this post in threaded view
|

Re: Unable to get asciidoctor-diagram working

mojavelinux
Administrator
I installed asciidoctor-diagram through `gem`: 

Are you using RVM?

I simply don't trust the installation of Ruby on OSX and it doesn't surprise me that it doesn't work if you use that installation.

-Dan

On Fri, Sep 22, 2017 at 12:37 AM, wimdeblauwe [via Asciidoctor :: Discussion] <[hidden email]> wrote:
Hi,

I am trying to get asciidoctor-diagram working for the first time. I am using asciidctor 1.5.6.1:

Wims-MacBook-Pro:docs wdb$ asciidoctor -v
Asciidoctor 1.5.6.1 [http://asciidoctor.org]
Runtime Environment (ruby 2.4.2p198 (2017-09-14 revision 59899) [x86_64-darwin16]) (lc:US-ASCII fs:US-ASCII in:- ex:US-ASCII)

When I run "asciidoctor -r asciidoctor-diagram", I get:

asciidoctor: FAILED: 'asciidoctor-diagram' could not be loaded
  Use --trace for backtrace

Also with asciidoctor-pdf, I get the same error. Version:

Wims-MacBook-Pro:docs wdb$ asciidoctor-pdf -v
Asciidoctor PDF 1.5.0.alpha.16 using Asciidoctor 1.5.6.1 [http://asciidoctor.org]
Runtime Environment (ruby 2.4.2p198 (2017-09-14 revision 59899) [x86_64-darwin16]) (lc:US-ASCII fs:US-ASCII in:- ex:US-ASCII)

I installed asciidoctor-diagram through `gem`:

Wims-MacBook-Pro:docs wdb$ gem which asciidoctor-diagram
/Library/Ruby/Gems/2.0.0/gems/asciidoctor-diagram-1.5.5/lib/asciidoctor-diagram.rb

Any idea what else I can try?


If you reply to this email, your message will be added to the discussion below:
http://discuss.asciidoctor.org/Unable-to-get-asciidoctor-diagram-working-tp5940.html
To start a new topic under Asciidoctor :: Discussion, email [hidden email]
To unsubscribe from Asciidoctor :: Discussion, click here.
NAML



--
Dan Allen | @mojavelinux | https://twitter.com/mojavelinux
Reply | Threaded
Open this post in threaded view
|

Re: Unable to get asciidoctor-diagram working

wimdeblauwe
I was not. Seems to be better indeed using RVM.