Umlauts in Asciidoctor-Diagram

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Umlauts in Asciidoctor-Diagram

Clemens
Hello,

last topic on my "Get things working in Asciidoctor-pdf" is the following.

I create a diagram using asciidoctor-diagram with ditaa.
Everything works fine, except one thing. As I write in german I use umlauts like "ä,ö,ü,ß".

Unfortunately they are shown as squares in the diagram. Everywhere else in the document they are shown correctly.

I defined the encoding in my Asciidoc file as UTF-8 (:encoding: utf-8) and also my my text editor is set to UTF-8.

When I do the rendering with firefox plugin, everything works flawlessly.

I assume that asciidoctor-diagram plugin takes a wrong encoding from somewhere, but I don't know how to change that.

I hope that's the correct place to post, as asciidoctor-diagram or ditaa plugin might be the place to search for the problem.

Thank you for your suggestions.

Best regards,

Clemens

Reply | Threaded
Open this post in threaded view
|

Re: Umlauts in Asciidoctor-Diagram

1marc1
Clemens,

I haven't used asciidoctor-diagram, but the lesson from the previous issue is: make sure the glyphs are present in the font that is being used. Open the font in FontForge and check that the glyph your are trying to render exists.

Marc.
Reply | Threaded
Open this post in threaded view
|

Re: Umlauts in Asciidoctor-Diagram

Clemens
Dear Marc,

I agree, the fonts probably misses the corresponding glyphs.
However I don't know which font is used. It is not the one that is used for the rest of the document where the diagram is embedded In the rest of the document all umlauts are shown correctly.

Seems like diagram seems to take another font (why and from where I don't know).

For me it's interesting to know if anyone can tell me how to change the font parameter in the Asciidoc file.