Strategy for providing asciidoctorj-pdf alpha12

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Strategy for providing asciidoctorj-pdf alpha12

Robert.Panzer
Hi,

I just had a short look at asciidoctor-pdf 1.5.0-alpha12 and indeed it's not installable with JRuby 1.7.x so I don't get it easily into the Asciidoctorj build.

That's why I want do collect ideas for possible solutions to provide it with an asciidoctorj 1.5.4.2.
Possible solutions that come up to my mind are
- Lift the dependency on JRuby to 9000 at least for asciidoctorj-pdf and the distribution. (This would raise the Java requirement to 1.7 and JRuby 9000+Asciidoctorj doesn't work properly on Win now)
- Provide asciidoctorj-pdf 1.5.0-alpha12 only with asciidoctorj 1.6.0-alpha4 which is already on JRuby 9000. Current users of asciidoctorj 1.5.x could manually upgrade the asciidoctorj-pdf version if they also use JRuby 9000.

(This could also open the door to upgrade the version of prawn. The version we use has some limitations.)

Any additional solutions?

Cheers
Robert
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Strategy for providing asciidoctorj-pdf alpha12

Robert.Panzer
A dirty solution to make none of my proposed changes could be to use JRuby 9000 to install the gem but keep the dependency on JRuby 1.7:

jruby {
  defaultRepositories = false
  defaultVersion = '9.1.2.0' // instead of jrubyVersion = 1.7.25
  execVersion = '9.1.2.0' // instead of jrubyVersion = 1.7.25
  // TODO I'd like to be able to customize the name of the gemInstallDir
}

A first test with an SVG image seems to work, I don't know the implications of this approach though.

Currently installation of prawn-svg fails because Ruby >=2.0 is required.
JRuby 1.7.x supports a bit of Ruby 2.0 but apparently not enough to declare it as supported during gem installation.

Thoughts on this approach?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Strategy for providing asciidoctorj-pdf alpha12

mojavelinux
Administrator
Robert,

I think using JRuby 9k to handle the installation is a great approach. The only thing that is stopping these gems from working on Ruby 1.9.3 is the check at installation time.

> Currently installation of prawn-svg fails because Ruby >=2.0 is required.

This is a regression in Asciidoctor PDF (caused by a lack of tests). I'm fixing this for 1.5.0.alpha.13. But forcing the lower version in AsciidoctorJ PDF is not ideal. A better approach is to get us past the installation step by using JRuby 9k.

(I wonder if this technique would allow us to upgrade to Prawn 2 as well. Again, it's only the gemspec requirement that is breaking 1.9.3 support).

-Dan

On Sun, Aug 21, 2016 at 7:27 AM, Robert.Panzer [via Asciidoctor :: Discussion] <[hidden email]> wrote:
A dirty solution to make none of my proposed changes could be to use JRuby 9000 to install the gem but keep the dependency on JRuby 1.7:

jruby {
  defaultRepositories = false
  defaultVersion = '9.1.2.0' // instead of jrubyVersion = 1.7.25
  execVersion = '9.1.2.0' // instead of jrubyVersion = 1.7.25
  // TODO I'd like to be able to customize the name of the gemInstallDir
}

A first test with an SVG image seems to work, I don't know the implications of this approach though.

Currently installation of prawn-svg fails because Ruby >=2.0 is required.
JRuby 1.7.x supports a bit of Ruby 2.0 but apparently not enough to declare it as supported during gem installation.

Thoughts on this approach?


If you reply to this email, your message will be added to the discussion below:
http://discuss.asciidoctor.org/Strategy-for-providing-asciidoctorj-pdf-alpha12-tp4896p4899.html
To start a new topic under Asciidoctor :: Discussion, email [hidden email]
To unsubscribe from Asciidoctor :: Discussion, click here.
NAML



--
Dan Allen | @mojavelinux | https://twitter.com/mojavelinux
Loading...