Problem with callouts in XML source block: probably user error

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Problem with callouts in XML source block: probably user error

JezPrime
Hi all,

I'm busy tearing my hair out because I'm sure it's something I'm doing that's particularly dumb, but I can't see what it is.

Using asciidoctor 1.5.4 on ruby 2.3.1, when interpreting an XML source block using coderay as the syntax highlighter, converting to HTML 5, I see a beautifully syntax highlighted code block, but instead of looking like black circles with white numbers in them, my callouts just look like bold numbers in brackets.

Looking through the source, the generated html for the callout looks like (1) wrapped in bold, with the opening bold tag having class "conum" but with no data-value attribute set. (I tried posting the actual tag in here but it wasn't being rendered by the forum)

Looking through generated correct-looking examples on the web, it would appear it should look like

(b class="conum" data-value="1")(/b) but with brackets replaced by angle brackets

If I change my generated html to match this, it looks correct, supporting that hypothesis. So anyone know what it is I'm missing to make the generated output correct? I was originally using the maven plugin with 1.5.3 but fell back to manual asciidoctor runs to try and eliminate maven plugin error, and I see the same with command-line 1.5.4.

The callout comment follows an xml line (so it's appended to a line, just in case that would cause a problem), the line looks like

                    <linkcss>true</linkcss>  

(the callout comment is being hidden by the forum renderer, but it is an angle open bracket then an exclamation mark, then two minuses, then the number 1, then two minuses then an angle close bracket).

(yes, I was documenting my use of the maven plugin for posterity)

Thanks in advance to anyone for any help you can offer, I'm sure it's operator error because so many others are getting the correct results, I just don't know what it is I'm doing wrong.

If I'm not telling you enough please ask me for more detail :)
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem with callouts in XML source block: probably user error

mojavelinux
Administrator
In order to get callout number bubbles, you need to enable icon fonts (even though these are actually done with CSS).

:icons: font

Let me know if that works out for you.

Cheers,

-Dan

On Thu, May 19, 2016 at 3:40 PM, JezPrime [via Asciidoctor :: Discussion] <[hidden email]> wrote:
Hi all,

I'm busy tearing my hair out because I'm sure it's something I'm doing that's particularly dumb, but I can't see what it is.

Using asciidoctor 1.5.4 on ruby 2.3.1, when interpreting an XML source block using coderay as the syntax highlighter, converting to HTML 5, I see a beautifully syntax highlighted code block, but instead of looking like black circles with white numbers in them, my callouts just look like bold numbers in brackets.

Looking through the source, the generated html for the callout looks like (1)
Looking through generated correct-looking examples on the web, it would appear it should look like



If I change my generated html to match this, it looks correct, supporting that hypothesis. So anyone know what it is I'm missing to make the generated output correct? I was originally using the maven plugin with 1.5.3 but fell back to manual asciidoctor runs to try and eliminate maven plugin error, and I see the same with command-line 1.5.4.

The callout comment follows an xml line (so it's appended to a line, just in case that would cause a problem), the line looks like

                    <linkcss>true</linkcss> 

(yes, I was documenting my use of the maven plugin for posterity)

Thanks in advance to anyone for any help you can offer, I'm sure it's operator error because so many others are getting the correct results, I just don't know what it is I'm doing wrong.

If I'm not telling you enough please ask me for more detail :)


If you reply to this email, your message will be added to the discussion below:
http://discuss.asciidoctor.org/Problem-with-callouts-in-XML-source-block-probably-user-error-tp4685.html
To start a new topic under Asciidoctor :: Discussion, email [hidden email]
To unsubscribe from Asciidoctor :: Discussion, click here.
NAML



--
Dan Allen | @mojavelinux | http://google.com/profiles/dan.j.allen
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem with callouts in XML source block: probably user error

JezPrime
Awesome, thanks Dan, problem solved. I was confused by the fact that the "icon fonts" section appears after the section on XML callouts which shows the "icon fonts" style display of the callout (and describes it as white on black) so thought icon fonts was another mechanism for achieving the same effect.

Would you mind if I submitted a very small PR to the XML Callouts section of the documentation to state explicitly that if icon fonts are not enabled then the callout rendering will appear different, or is the difference specific to HTML generation?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem with callouts in XML source block: probably user error

mojavelinux
Administrator
I would be very glad to receive your PR to improve the documentation. We're always trying to make the documentation clearer and there's no better way than from the perspective of someone using it!

Cheers,

-Dan

On Fri, May 20, 2016 at 1:10 AM, JezPrime [via Asciidoctor :: Discussion] <[hidden email]> wrote:
Awesome, thanks Dan, problem solved. I was confused by the fact that the "icon fonts" section appears after the section on XML callouts which shows the "icon fonts" style display of the callout (and describes it as white on black) so thought icon fonts was another mechanism for achieving the same effect.

Would you mind if I submitted a very small PR to the XML Callouts section of the documentation to state explicitly that if icon fonts are not enabled then the callout rendering will appear different, or is the difference specific to HTML generation?


If you reply to this email, your message will be added to the discussion below:
http://discuss.asciidoctor.org/Problem-with-callouts-in-XML-source-block-probably-user-error-tp4685p4693.html
To start a new topic under Asciidoctor :: Discussion, email [hidden email]
To unsubscribe from Asciidoctor :: Discussion, click here.
NAML



--
Dan Allen | @mojavelinux | http://google.com/profiles/dan.j.allen
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem with callouts in XML source block: probably user error

JezPrime
Thanks very much Dan, very small PR (but hopefully clear) submitted for the doc. It will probably only affect a very few readers but if it saves repetition of the same question then it's worthwhile.

Thanks again for your very quick and accurate response.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem with callouts in XML source block: probably user error

mojavelinux
Administrator
Thanks! Even if we can save one person time, that's significant!

Cheers,

-Dan

On Fri, May 20, 2016 at 4:42 AM, JezPrime [via Asciidoctor :: Discussion] <[hidden email]> wrote:
Thanks very much Dan, very small PR (but hopefully clear) submitted for the doc. It will probably only affect a very few readers but if it saves repetition of the same question then it's worthwhile.

Thanks again for your very quick and accurate response.


If you reply to this email, your message will be added to the discussion below:
http://discuss.asciidoctor.org/Problem-with-callouts-in-XML-source-block-probably-user-error-tp4685p4697.html
To start a new topic under Asciidoctor :: Discussion, email [hidden email]
To unsubscribe from Asciidoctor :: Discussion, click here.
NAML



--
Dan Allen | @mojavelinux | http://google.com/profiles/dan.j.allen
Loading...