How to disable the header and footer from Gradle

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

How to disable the header and footer from Gradle

graemerocher
I'm trying to produce the raw HTML to embed elsewhere using the asciidoctor Gradle plugin.

I have this in my build.gradle:

    attributes 'experimental'  : 'true',
               'compat-mode'   : 'true',              
               'embedded'      : 'true',
               'header_footer' : null,
               'icons'         : 'font',              
               'version'       : project.version,
               'sourcedir'     : "$checkOutDir/grails-src"

However, it doesn't appear to work, and I get the header and footer. I have tried passing false to the "header_footer" option but that doesn't seem to work either. I have the 1.5.4 version of asciidoctor configured:

asciidoctorj {
    version = '1.5.4'
}

Any ideas how to make this happen?
Reply | Threaded
Open this post in threaded view
|

Re: How to disable the header and footer from Gradle

graemerocher
Nevermind, found the answer. It has to be configured in "options" instead:

    options header_footer: false
    attributes 'experimental'  : 'true',
               'compat-mode'   : 'true',                              
               'icons'         : 'font',              
               'version'       : project.version,
               'sourcedir'     : "$checkOutDir/grails-src"