Encoding Problem on Time Zone in Last Update Date Section

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Encoding Problem on Time Zone in Last Update Date Section

İsmail Arılık
Hi all.

I have an encoding problem in Last Update Date section of my generated HTML file. It looks like that:

"""
Sürüm 0.1
Son güncelleme 2017-05-11 20:36:22 Tⁿrkiye Standart Saati
"""

These are some Turkish words. Here "Tⁿrkiye Standart Saati" means "Turkish Standard Time". But "Tⁿrkiye" should be "Türkiye". I researched and found that datetime format cannot be changed for now. Manually setting datetime via proper variables can be a solution for that but I don't want to write datetime everytime with my hands. So is there anyone can suggest a solution to my problem?

Thanks.
Reply | Threaded
Open this post in threaded view
|

Re: Encoding Problem on Time Zone in Last Update Date Section

mojavelinux
Administrator

On Thu, May 11, 2017 at 12:20 PM, İsmail Arılık [via Asciidoctor :: Discussion] <[hidden email]> wrote:
Manually setting datetime via proper variables can be a solution for that but I don't want to write datetime everytime with my hands.

I recommend using a script to call Asciidoctor that sets this variable correctly. That way, you don't have to type it manually.

I'm not sure why you are getting the incorrect glyph. If you pass UTF-8 encoded text to Asciidoctor, it will be handled correctly.

Keep in mind that the fonts in the default Asciidoctor stylesheet don't support all characters (as they are served through Google Fonts). However, they should support most characters in Latin-based languages. When a glyph is not found in the found, it falls back to a font provided by the system. I don't think that's the case here, but I just wanted to mention that.

-Dan


--
Dan Allen | @mojavelinux | https://twitter.com/mojavelinux