Asciidoctor Maven plugin and Asciidoclet for Asciidoctor 1.5.0

classic Classic list List threaded Threaded
6 messages Options
Ole
Reply | Threaded
Open this post in threaded view
|

Asciidoctor Maven plugin and Asciidoclet for Asciidoctor 1.5.0

Ole

Hi,

I am a Java programmer and found Asciidoctor some weeks ago.

I didn't find a way to make nice graphics back then. But 'Hooray!', Asciidoctor 1.5.0 provides exactly this. Thanks a lot!

Since graphics are a very central part of my documentation I would like to use Asciidoctor 1.5.0 everywhere. :-)

Especially interesting are:

  • Using it in Maven via the Asciidoctor Maven plugin and the Maven site plugin.
  • Using it in JavaDoc via the Asciidoclet.

The Maven plugin documentation says:

"This plugin tracks the version of Asciidoctor, so you can use which ever version of Asciidoctor you prefer."

But I can't find a version 1.5.0.

Is the name change from Asciidoctor Java integration to Asciidoctorj part of the problem?

I managed to patch the current Asciidoctorj JAR with the necessary dependencies for command line usage and with Asciidoctor Diagram. (Phwe!)

So there seems to be no deeper technical problem. :-)

It would be so nice if I could use the Maven plugin and the doclet (Version 1.5.0) in a few weeks. Is there anything I (Java experience: a lot; Ruby experience: none) can do to help?

Best regards

Ole

Reply | Threaded
Open this post in threaded view
|

Re: Asciidoctor Maven plugin and Asciidoclet for Asciidoctor 1.5.0

LightGuardjp
Administrator
Wow, lots are chomping at the bit for the release of the plugin :) I'm currently working on it.

If you have some time and would like to tackle some of the issues label "Community Help Wanted" it'll help.

Sent from Mailbox


On Wed, Aug 20, 2014 at 11:12 AM, Ole [via Asciidoctor :: Discussion] <[hidden email]> wrote:

Hi,

I am a Java programmer and found Asciidoctor some weeks ago.

I didn't find a way to make nice graphics back then. But 'Hooray!', Asciidoctor 1.5.0 provides exactly this. Thanks a lot!

Since graphics are a very central part of my documentation I would like to use Asciidoctor 1.5.0 everywhere. :-)

Especially interesting are:

  • Using it in Maven via the Asciidoctor Maven plugin and the Maven site plugin.
  • Using it in JavaDoc via the Asciidoclet.

The Maven plugin documentation says:

"This plugin tracks the version of Asciidoctor, so you can use which ever version of Asciidoctor you prefer."

But I can't find a version 1.5.0.

Is the name change from Asciidoctor Java integration to Asciidoctorj part of the problem?

I managed to patch the current Asciidoctorj JAR with the necessary dependencies for command line usage and with Asciidoctor Diagram. (Phwe!)

So there seems to be no deeper technical problem. :-)

It would be so nice if I could use the Maven plugin and the doclet (Version 1.5.0) in a few weeks. Is there anything I (Java experience: a lot; Ruby experience: none) can do to help?

Best regards

Ole




If you reply to this email, your message will be added to the discussion below:
http://discuss.asciidoctor.org/Asciidoctor-Maven-plugin-and-Asciidoclet-for-Asciidoctor-1-5-0-tp2027.html
To start a new topic under Asciidoctor :: Discussion, email [hidden email]
To unsubscribe from Asciidoctor :: Discussion, click here.
NAML

Reply | Threaded
Open this post in threaded view
|

Re: Asciidoctor Maven plugin and Asciidoclet for Asciidoctor 1.5.0

mojavelinux
Administrator
AsciidoctorJ, the Asciidoctor Gradle plugin and the Asciidoctor Maven plugin are all now released. See the blog for more details.


Asciidoclet is on the way. We had to iron out some last minute design issues before it was ready.

Cheers!

-Dan



On Wed, Aug 20, 2014 at 11:12 AM, LightGuardjp [via Asciidoctor :: Discussion] <[hidden email]> wrote:
Wow, lots are chomping at the bit for the release of the plugin :) I'm currently working on it.

If you have some time and would like to tackle some of the issues label "Community Help Wanted" it'll help.

Sent from Mailbox


On Wed, Aug 20, 2014 at 11:12 AM, Ole [via Asciidoctor :: Discussion] <[hidden email]> wrote:

Hi,

I am a Java programmer and found Asciidoctor some weeks ago.

I didn't find a way to make nice graphics back then. But 'Hooray!', Asciidoctor 1.5.0 provides exactly this. Thanks a lot!

Since graphics are a very central part of my documentation I would like to use Asciidoctor 1.5.0 everywhere. :-)

Especially interesting are:

  • Using it in Maven via the Asciidoctor Maven plugin and the Maven site plugin.
  • Using it in JavaDoc via the Asciidoclet.

The Maven plugin documentation says:

"This plugin tracks the version of Asciidoctor, so you can use which ever version of Asciidoctor you prefer."

But I can't find a version 1.5.0.

Is the name change from Asciidoctor Java integration to Asciidoctorj part of the problem?

I managed to patch the current Asciidoctorj JAR with the necessary dependencies for command line usage and with Asciidoctor Diagram. (Phwe!)

So there seems to be no deeper technical problem. :-)

It would be so nice if I could use the Maven plugin and the doclet (Version 1.5.0) in a few weeks. Is there anything I (Java experience: a lot; Ruby experience: none) can do to help?

Best regards

Ole




If you reply to this email, your message will be added to the discussion below:
http://discuss.asciidoctor.org/Asciidoctor-Maven-plugin-and-Asciidoclet-for-Asciidoctor-1-5-0-tp2027.html
To start a new topic under Asciidoctor :: Discussion, email [hidden email]
To unsubscribe from Asciidoctor :: Discussion, click here.
NAML




If you reply to this email, your message will be added to the discussion below:
http://discuss.asciidoctor.org/Asciidoctor-Maven-plugin-and-Asciidoclet-for-Asciidoctor-1-5-0-tp2027p2028.html
To start a new topic under Asciidoctor :: Discussion, email [hidden email]
To unsubscribe from Asciidoctor :: Discussion, click here.
NAML



--
Reply | Threaded
Open this post in threaded view
|

Re: Asciidoctor Maven plugin and Asciidoclet for Asciidoctor 1.5.0

mojavelinux
Administrator
In reply to this post by LightGuardjp
Btw, the best way to help in the future is to look through the issue tracker for the project and see where we're stuck. You can see what's remaining in Asciidoclet here:



On Sat, Aug 23, 2014 at 4:24 AM, Dan Allen <[hidden email]> wrote:
AsciidoctorJ, the Asciidoctor Gradle plugin and the Asciidoctor Maven plugin are all now released. See the blog for more details.


Asciidoclet is on the way. We had to iron out some last minute design issues before it was ready.

Cheers!

-Dan



On Wed, Aug 20, 2014 at 11:12 AM, LightGuardjp [via Asciidoctor :: Discussion] <[hidden email]> wrote:
Wow, lots are chomping at the bit for the release of the plugin :) I'm currently working on it.

If you have some time and would like to tackle some of the issues label "Community Help Wanted" it'll help.

Sent from Mailbox


On Wed, Aug 20, 2014 at 11:12 AM, Ole [via Asciidoctor :: Discussion] <[hidden email]> wrote:

Hi,

I am a Java programmer and found Asciidoctor some weeks ago.

I didn't find a way to make nice graphics back then. But 'Hooray!', Asciidoctor 1.5.0 provides exactly this. Thanks a lot!

Since graphics are a very central part of my documentation I would like to use Asciidoctor 1.5.0 everywhere. :-)

Especially interesting are:

  • Using it in Maven via the Asciidoctor Maven plugin and the Maven site plugin.
  • Using it in JavaDoc via the Asciidoclet.

The Maven plugin documentation says:

"This plugin tracks the version of Asciidoctor, so you can use which ever version of Asciidoctor you prefer."

But I can't find a version 1.5.0.

Is the name change from Asciidoctor Java integration to Asciidoctorj part of the problem?

I managed to patch the current Asciidoctorj JAR with the necessary dependencies for command line usage and with Asciidoctor Diagram. (Phwe!)

So there seems to be no deeper technical problem. :-)

It would be so nice if I could use the Maven plugin and the doclet (Version 1.5.0) in a few weeks. Is there anything I (Java experience: a lot; Ruby experience: none) can do to help?

Best regards

Ole




If you reply to this email, your message will be added to the discussion below:
http://discuss.asciidoctor.org/Asciidoctor-Maven-plugin-and-Asciidoclet-for-Asciidoctor-1-5-0-tp2027.html
To start a new topic under Asciidoctor :: Discussion, email [hidden email]
To unsubscribe from Asciidoctor :: Discussion, click here.
NAML




If you reply to this email, your message will be added to the discussion below:
http://discuss.asciidoctor.org/Asciidoctor-Maven-plugin-and-Asciidoclet-for-Asciidoctor-1-5-0-tp2027p2028.html
To start a new topic under Asciidoctor :: Discussion, email [hidden email]
To unsubscribe from Asciidoctor :: Discussion, click here.
NAML



--



--
Ole
Reply | Threaded
Open this post in threaded view
|

Re: Asciidoctor Maven plugin and Asciidoclet for Asciidoctor 1.5.0

Ole
Great news! Thanks a lot!
And Asciidoclet has only one issue left: publishing to bin tray!
Seems that I can prepare to celebrate!  
Reply | Threaded
Open this post in threaded view
|

Re: Asciidoctor Maven plugin and Asciidoclet for Asciidoctor 1.5.0

johncarl81

You can celebrate Ole, just closed the remaining issue on Asciidoclet!

On Aug 26, 2014 9:47 AM, "Ole [via Asciidoctor :: Discussion]" <[hidden email]> wrote:
Great news! Thanks a lot!
And Asciidoclet has only one issue left: publishing to bin tray!
Seems that I can prepare to celebrate!  


If you reply to this email, your message will be added to the discussion below:
http://discuss.asciidoctor.org/Asciidoctor-Maven-plugin-and-Asciidoclet-for-Asciidoctor-1-5-0-tp2027p2080.html
To start a new topic under Asciidoctor :: Discussion, email [hidden email]
To unsubscribe from Asciidoctor :: Discussion, click here.
NAML