Asciidoctor 1.5.6 not compatible with Asciidoctor Diagram 1.5.4

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Asciidoctor 1.5.6 not compatible with Asciidoctor Diagram 1.5.4

mojavelinux
Administrator
In case you haven't seen it, Asciidoctor 1.5.6 is out.


That's the good news. The bad news is that we discovered shortly after that Asciidoctor 1.5.6 is not compatible with Asciidoctor Diagram 1.5.4. We'll need a new release of Asciidoctor Diagram. We've sorted out a fix and Pepijn said he will be putting out a new release soon for you to use.

To avoid this problem in the future, we're setting up a build pipeline for the ecosystem that gets triggered each time a change goes into master. So far, Asciidoctor.js and AsciidoctorJ are enlisted in this pipeline, but obviously we'll want to get Asciidoctor Diagram in there as well.

So spread the word, if you upgrade to Asciidoctor 1.5.6 and you're using Asciidoctor Diagram, you'll also need to upgrade Asciidoctor Diagram (likely 1.5.5).

Cheers,

-Dan

--
Dan Allen | @mojavelinux | https://twitter.com/mojavelinux
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Asciidoctor 1.5.6 not compatible with Asciidoctor Diagram 1.5.4

mojavelinux
Administrator
Asciidoctor Diagram 1.5.5 is now available. You will need to use this version if you want to use Asciidoctor Diagram with Asciidoctor 1.5.6.

https://rubygems.org/gems/asciidoctor-diagram

Thanks to Pepijn for turning this release around so quickly, and to Robert for helping to identify the problem and the fix.

Cheers,

-Dan

p.s. Robert is working on the AsciidoctorJ 1.5.6 release. In fact, this problem was detected during QA while preparing that release.
Loading...