Anchor in Table, xreflabel not shown in reference.

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Anchor in Table, xreflabel not shown in reference.

Clemens
Hello,

please consider the following example:

|======
| Test a |Testb
| [[ref,Test]] Test c | Testc
|======

Show the <<ref>> .

The table is shown correctly. However the last sentence gives me:
"Show the [ref] ."

I would have expected "Show the Test" .

It works if I place the anchor outside the table, but I need it inside.

Thank you for any suggestions,

Clemens


Reply | Threaded
Open this post in threaded view
|

Re: Anchor in Table, xreflabel not shown in reference.

mojavelinux
Administrator
If you upgrade to Asciidoctor 1.5.7.1, I think you'll find that this now works. It's related to issue #2257.

Cheers,

-Dan

On Thu, May 17, 2018 at 6:44 AM, Clemens [via Asciidoctor :: Discussion] <[hidden email]> wrote:
Hello,

please consider the following example:

|======
| Test a |Testb
| [[ref,Test]] Test c | Testc
|======

Show the <<ref>> .

The table is shown correctly. However the last sentence gives me:
"Show the [ref] ."

I would have expected "Show the Test" .

It works if I place the anchor outside the table, but I need it inside.

Thank you for any suggestions,

Clemens





If you reply to this email, your message will be added to the discussion below:
http://discuss.asciidoctor.org/Anchor-in-Table-xreflabel-not-shown-in-reference-tp6337.html
To start a new topic under Asciidoctor :: Discussion, email [hidden email]
To unsubscribe from Asciidoctor :: Discussion, click here.
NAML



--
Dan Allen | @mojavelinux | https://twitter.com/mojavelinux
Reply | Threaded
Open this post in threaded view
|

Re: Anchor in Table, xreflabel not shown in reference.

Clemens
In reply to this post by Clemens
Thank you. That solved my Problem.
Reply | Threaded
Open this post in threaded view
|

Re: Anchor in Table, xreflabel not shown in reference.

mojavelinux
Administrator
Yeah!

On Fri, May 18, 2018 at 12:46 AM, Clemens [via Asciidoctor :: Discussion] <[hidden email]> wrote:
Thank you. That solved my Problem.


If you reply to this email, your message will be added to the discussion below:
http://discuss.asciidoctor.org/Anchor-in-Table-xreflabel-not-shown-in-reference-tp6337p6341.html
To start a new topic under Asciidoctor :: Discussion, email [hidden email]
To unsubscribe from Asciidoctor :: Discussion, click here.
NAML



--
Dan Allen | @mojavelinux | https://twitter.com/mojavelinux